SOLVED: Raising Minimum Required Version to PHP 7.2 for next version? -> Nope!


(Sebastian Kurfuerst) #1

Hey everybody,

Neos currently requires PHP >= 7.1. I suggest to raise this to PHP >= 7.2 starting at the next released version, so that we can embrace properly working return types and optional return types. I just stumbled over this while moving some Event Sourced CR code (which is PHP >=7.2) into Neos.ContentRepository.

I’d like to poll if this is fine for everybody – if not, please reply to this post and add some reasons why you’d like to keep PHP 7.1 as min dependency.

  • raise minimum PHP version to PHP 7.2 for next release
  • keep minimum PHP version at PHP 7.1 for next release (please leave comment with reason)

0 voters

Thanks,
Sebastian
PS: To clarify: This poll is open for the whole community, not just core members :slight_smile:


(Christian Müller) #2

We decided a while ago that this constitutes a breaking change and happens only in major versions AFAIK.


(Robert Lemke) #3

As much as I’d like to use 7.2 only (and of course I do in my own projects), I need to agree with @christianm here – it’s a breaking change by our definition so far and that means, we should provide a LTS version with 7.1 before we switch to 7.2.

Always remember how slow hosting companies and bigger corporations are with migrating to modern PHP versions …


(Alexander Berl) #4

What both Christian and Robert said. It’s a breaking change. I’d love to raise to 7.2 ASAP, but forcing that for a LTS will just prevent adoption of that LTS version. Let’s raise with next major. Maybe we can even jump directly to 7.3 by then.


(Bastian Waidelich) #5

This part puzzles me. PHP 7.1 has nullable return types - which feature exactly do you miss ?


(Martin Ficzel) #6

I also consider this breaking for a minor release. It is fine if the eventSourcedCR packages require PHP 7.2 but not the core itself before Neos 5 / Flow 6.


(Soren Malling) #7

Are we talking about the 6.0 release of Flow? Or the 5.X release of Flow ? I’ve voted yes, because I beleive we are talking about the 6.0 release of Flow.


(Aske Ertmann) #8

As far as I understood it was for the upcoming 5.2 release and thus 5.3 LTS release. For the 6.0 release, we’ll definitely raise it to 7.2, probably 7.3


(Sebastian Kurfuerst) #9

Hey everybody,

sorry for the confusion, @bwaidelich is totally right :slight_smile: I somehow misinterpreted a bug we were hitting in Travis and thought it would be a PHP compatibility issue, which was not true in fact.

So, sorry for the confusion - and let’s keep PHP 7.1 for the 5.2 release :slight_smile:

All the best,
Sebastian