[SOLVED] Update to newest patch version (4.3.13 > 4.3.19)

Good morning,

how do I update Neos to the latest patch version? Currently we’re running Neos 4.3.13 and I should update it to 4.3.19. Our composer.json currently looks like this:

"require": {
    "neos/neos": "~4.3.0",
    "neos/nodetypes": "~4.3.0",
    "neos/site-kickstarter": "~4.3.0",
    "neos/seo": "~2.0",
    "neos/setup": "~4.0",
    "flowpack/neos-frontendlogin": "~3.0",
    "neos/redirecthandler-neosadapter": "~2.0",
    "neos/redirecthandler-databasestorage": "~2.0",
    "neos/form-builder": "^1.0",
    "neos/swiftmailer": "^6.0",
    "flownative/neos-compressor": "^2.0",
    "neos/neos-ui": "^1.4",
    "neos/ldap": "^1.0",
    "sitegeist/silhouettes": "^1.1",
    "flowpack/searchplugin": "^4.0",
    "flowpack/elasticsearch-contentrepositoryadaptor": "^5.0"
}

I thought I just have to execute “composer update neos/neos”, but nothing changes. Even if I change “neos/neos” to “4.3.*”. Can someone help me please?

I usually do `` composer update as you usually not only want the neos neos package to be updated but also all dependencies. Very likely updating a single neos package will not work as many neos packages require each other in the exact same version like"neos/media": “self.version”` from nodetypes. See: https://github.com/neos/neos-nodetypes/blob/7.2.0/composer.json

Nevermind, I think it was my own fault. :see_no_evil:
When I executed “composer update” I got the following errors and I didn’t know why.

Problem 1
    - neos/behat dev-master requires neos/flow ~7.0 || dev-master -> satisfiable by neos/flow[7.0.4, 7.0.5, 7.0.10, 7.0.6, 7.0.7, 7.0.8, 7.0.9, 7.1.0, 7.1.1, 7.1.2, 7.1.3, 7.1.4, 7.2.0, 7.2.1, 7.0.0, 7.0.1, 7.0.2, 7.0.3].
    - neos/behat dev-master requires neos/flow ~7.0 || dev-master -> satisfiable by neos/flow[7.0.4, 7.0.5, 7.0.10, 7.0.6, 7.0.7, 7.0.8, 7.0.9, 7.1.0, 7.1.1, 7.1.2, 7.1.3, 7.1.4, 7.2.0, 7.2.1, 7.0.0, 7.0.1, 7.0.2, 7.0.3].
    - neos/flow 7.0.3 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.0.2 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.0.1 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.0.0 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.2.1 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.2.0 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.1.4 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.1.3 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.1.2 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.1.1 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.1.0 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.0.9 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.0.8 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.0.7 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.0.6 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.0.10 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.0.5 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - neos/flow 7.0.4 requires php ^7.3 || ^8.0 -> your PHP version (7.2.34) does not satisfy that requirement.
    - Installation request for neos/behat dev-master -> satisfiable by neos/behat[dev-master].

This happened because require-dev contained neos/behat:

"require-dev": {
    "neos/buildessentials": "5.3.x-dev",
    "mikey179/vfsstream": "~1.6",
    "phpunit/phpunit": "~7",
    "symfony/css-selector": "~2.0",
    "neos/behat": "dev-master",
    "captainhook/plugin-composer": "^4.0"
},

I removed it and successfully updates Neos. :slight_smile:
Is neos/behat important for dev?

Only if you want to execute the behat tests of neos which is unlikely.
It is possible that you implemented your own behat tests but you would likely know that.
Most customer projects i have seen use phpunit tests at max.

Okay, thank you Martin :slight_smile: