Swiftmailer not doing anything


(Matthias Lang) #1

Hey there,

I have a confusing problem. I have an email form finisher and neos/swiftmailer installed and configured in the settings. It doesn’t work. I have been trying for hours to find the problem.
Debbuging doens’t work, it’s seems like Swiftmailer never gets activated. The code is similar to another project.

Any suggestions?


(Karsten Dambekalns) #2
  • check the output of ./flow configzration:show --type Settings --path Neos.SwiftMailer
  • check the loading order of packages, if the above seems wrong ./flow package:list --loading-order
  • configure the logging transport for SwiftMailer to see if it would have sent something
  • if it doesn’t, make sure there are actually recipients for the mail to be sent, otherwise nothing will happen

Hope that helps!


(Matthias Lang) #3

Hey @kdambekalns,

the output is:

transport:
    type: Swift_MailTransport
    options: {  }
    arguments: null

The options won’t load.
I rewrote the settings, but nothing happens. What may be the reason for this?

Thanks,
Matthias


(Soren Malling) #4

It seems like the configuration is being reset, that could be due to a wrong loading order mentioned by Karsten. How do you require the swiftmailer package and in what order is it listed compared to your own package?


(Matthias Lang) #5

Oh well, the site package is loaded before the swiftmailer package. How can i edit the loading order?

Thanks!


(Soren Malling) #6

Require it inside your Site package instead of the root composer.json


(Matthias Lang) #7

Hmmmm.

That seems right, but wasn’t there another way? Since now it always worked. May this have something to do with 4.0?


(Soren Malling) #8

The dependency order decides the merging of the Settings.yaml - you might just have been lucky :slight_smile: