Swiftmailer not doing anything

Hey there,

I have a confusing problem. I have an email form finisher and neos/swiftmailer installed and configured in the settings. It doesn’t work. I have been trying for hours to find the problem.
Debbuging doens’t work, it’s seems like Swiftmailer never gets activated. The code is similar to another project.

Any suggestions?

  • check the output of ./flow configzration:show --type Settings --path Neos.SwiftMailer
  • check the loading order of packages, if the above seems wrong ./flow package:list --loading-order
  • configure the logging transport for SwiftMailer to see if it would have sent something
  • if it doesn’t, make sure there are actually recipients for the mail to be sent, otherwise nothing will happen

Hope that helps!

Hey @kdambekalns,

the output is:

    type: Swift_MailTransport
    options: {  }
    arguments: null

The options won’t load.
I rewrote the settings, but nothing happens. What may be the reason for this?


It seems like the configuration is being reset, that could be due to a wrong loading order mentioned by Karsten. How do you require the swiftmailer package and in what order is it listed compared to your own package?

Oh well, the site package is loaded before the swiftmailer package. How can i edit the loading order?


Require it inside your Site package instead of the root composer.json


That seems right, but wasn’t there another way? Since now it always worked. May this have something to do with 4.0?

The dependency order decides the merging of the Settings.yaml - you might just have been lucky :slight_smile:

The loading order is essential and you should always require all plugin packages from within your site package to enforce the loading order.

Take a look at this single repository setup. The composer configuration comes from Christian and is genius. https://github.com/code-q-web-factory/Neos-Skeleton

@Matschess If that worked for you, please prefix your topic title with "[SOLVED] "