Systemsprache auf Deutsch umstellen, wie?

Hallo Leute,

ich habe im Moment zwar die Usersprache auf Deutsch aber ich möchte generell auch die Systemsprache von englisch auf deutsch umstellen.

Beim Googeln finde ich aber immer nur alte Infos, die nicht mehr gehen oder Multilanguage, die ich nicht will/brauche.

Ich kann in der Konfigurationsansicht zwar einen EN Eintrag finden, jedoch ist nirgends ersichtlich, wo die ganzen Einträge der Konfiguration platziert sind.

Also wie stelle ich FE & BE & System auf deutsch ohne weitere Sprachen?

Grüße und schönes WE
G.S.

Hey Gerd,

wie du richtig erkannt hast, gibt es mehrere Möglichkeiten der Sprachwahl:

  1. Sprache des Benutzers im Backend
  2. Sprache des Contents. Wenn keine Dimensions konfiguriert sind wie bei dir, dann ist die Sprache nicht gesetzt.
  3. Die Default Sprache, welche in diesem Fall die übersetzten Labels im Frontend bestimmt sowie auch die CLDR formatierten Datumsangaben.

Diese wird über:

Neos:
  Flow:
    i18n:
      defaultLocale: de

auf Deutsch gesetzt.

Ich empfehle hier folgende Konfiguration (wird auch in der Flow Doku beschrieben) damit es keine Probleme gibt, wenn irgendwo die Deutsche Fassung fehlt:

  Flow:
    i18n:
      defaultLocale: de
      fallbackRule:
        order:
          - en

Super, Danke Euch beiden.
Ich hatte einiges probiert aber auf das “i18n” bin ich nicht gekommen.

EDIT:
Wird leider nicht übernommen, die Systemsprache ist immer noch englisch und in der Konfigurationsübersicht steht auch noch “en”.

An was machst du die Systemsprache fest?
Welche Konfigurationsübersicht meinst du?
Du hast erwähnt, dass du Neos direkt auf einem Server konfigurierst, läuft Neos dort schon im Production Context, so dass deine Änderungen durch den Cache nicht sichtbar werden?

Neos läuft im “Production” Mode aber ich habe es noch nicht geschafft, den Cache zu löschen, da neos:flush:cache mit der Fehlermeldung abbricht, dass ich noch irgendwas weiteres angeben soll.

Ich konfiguriere Neos per SSH auf einem Shared Hosting Paket, was sonst recht gut funktioniert und ich viele Optionen dort einfach selbst konfigurieren kann (PHP Version, PHP Optionen, usw.).

Dann ist das der Grund, warum sich an der Einstellung nichts ändert. Die Konfiguration wird gecached.
Wenn du deinen Remote Server als Entwicklungsserver verwendest, solltest du ihn während der Entwicklungszeit im Context “Development” betreiben. Der Befehl zum Cache löschen heisst flow:cacahe:flush

Wie aber bereits erwähnt wurde, würde es sehr zu empfehlen, dass du dir eine lokale Entwicklungsumgebung einrichtest. Mit Docker vielleicht. Hier gibts dazu auch gerade eine aktuelle Anleitung: https://github.com/sandstorm/neos-kickstart

Mein @NetSecond nicht eher, dass er das Neos-Backen gerne für alle Benutzer standardmässig in deutscher Sprache haben möchte? Wie das möglich ist, wüsste ich auch nicht.

@daniellienert

./flow cache:flush

Unrecognized Command
Sorry, but the command “neos.flow:cache:flush” must be specified by its full command
identifier because it is a compile time command which cannot be resolved
from an abbreviated command identifier.

und

./flow flow:cache:flush

löscht nur den Development Cache.

@lorenzulrich
Das auch, ich möchte die Systemsprache auf Deutsch, dann ist auch die Backenduserdefaultsprache Deutsch.

Neos hat auch eine Einstellung für die default Backendsprache https://github.com/neos/neos-development-collection/blob/master/Neos.Neos/Configuration/Settings.yaml#L113

und

FLOW_CONTEXT=Production ./flow flow:cache:flush

löscht den Production Cache.

Super, Danke.

Die Systemsprache ist zwar immer noch englisch aber der Rest deutsch.
(Wird in der Konfiguration jetzt auch als “de” angezeigt.)

Was meinst du mit Systemsprache und dem Rest?

Wenn du alles korrekt konfigurierst, sollte im Backend im Prinzip alles Deutsch sein

Wenn ich in der Useradministration die Sprache auf “Systemstandard” einstelle, wird die BE Sprache wieder englisch.
Das heißt für mich: Die “Systemsprache” ist immer noch englisch.

Ist jetzt kein Beinbruch aber es hätte mich halt interessiert, wie man diese Systemstandardsprache eben auf deutsch umstellt.

Genau das sollte die von mir verlinkte Einstellung tun. Cache evtl nicht gelöscht nach der Umstellung?

Doch, i18n wurde ja auch aktualisiert und wird jetzt richtig angezeigt in der Konfiguration aber die Standard Systemsprache ist trotzdem englisch.

Bei mir sieht das so aus:

Dafür hab ich folgendes eingestellt:

Neos:
    Neos:
        userInterface:
            defaultLanguage: de

Super, Danke, das habe ich gesucht.

1 Like