The system cannot find the path specified


(Prafulla Kumar Sahu) #1

I have just started learning about neos and during installation I am getting one error, please help.

I am using windows 10 64bit, and PHP 7.2.4 and wamp 3.1.3 - 64bit
, if anything more, I need to specify, please let me know.

C:\wamp64\www\demo>php ./flow server:run
The system cannot find the path specified.

  Type: Neos\Flow\Core\Booting\Exception\SubProcessException
  Code: 1355480641
  File: C:\wamp64\www\demo\Packages\Framework\Neos.Flow\Classes\Core\Booting\Script
        s.php
  Line: 677

Open Data/Logs/Exceptions/20180706035535814625.txt for a full stack trace.

C:\wamp64\www\demo>php ./flow.bat server:run
@ECHO OFF

REM Replace the following line with the path to your PHP executable if required
REM This can include the php.ini to be used (for example "SET PHP=C:/php/php.exe -c C:/php/php.ini")

SET PHP=php.exe

%PHP% %~dp0Packages/Framework/Neos.Flow/Scripts/flow.php %*

I changed flow.bat file from
@ECHO OFF

REM Replace the following line with the path to your PHP executable if required
REM This can include the php.ini to be used (for example "SET PHP=C:/php/php.exe -c C:/php/php.ini")

SET PHP=php.exe

%PHP% %~dp0Packages/Framework/Neos.Flow/Scripts/flow.php %*

to

@ECHO OFF

REM Replace the following line with the path to your PHP executable if required
REM This can include the php.ini to be used (for example "SET PHP=C:/php/php.exe -c C:/php/php.ini")

SET PHP=C:/wamp64/bin/php/php7.2.4/php.exe -c C:/wamp64/bin/php/php7.2.4/php.ini

%PHP% %~dp0Packages/Framework/Neos.Flow/Scripts/flow.php %*

but that also not fixing the issue.

Also updated settings.yaml fiel to

#                                                                        #
# Configuration for the Flow Framework                                   #
#                                                                        #
# This file contains the default base configuration for the Flow         #
# Framework. Don't modify this file but add configuration options to     #
# the Settings.yaml file in the in global Configuration/ directory       #
# instead.                                                               #
#                                                                        #

Neos:
  Flow:
    # A section for compatibility flags that are deprecated.
    compatibility: []

    utility:
      lockStrategyClassName: 'Neos\Utility\Lock\FlockLockStrategy'
    core:
        phpBinaryPathAndFilename: 'C:/wamp64/bin/php/php7.2.4/php.exe'

but getting same problem.


(Bastian Heist) #2

Hi Prafulla,
one step further from your question on YouTube, it looks like :wink:
./flow.bat is designed to work without explictly using php to open it - you should just be able to do ./flow.bat server:run. If that doesnt work, could you post the contents of the provided error dump file (above, it would be Data/Logs/Exceptions/20180706035535814625.txt relative to your Neos folder) ?
Thanks!


(Prafulla Kumar Sahu) #3

Sir, that is showing

C:\wamp64\www\demo>./flow.bat server:run
'.' is not recognized as an internal or external command,
operable program or batch file.

log file contains

Exception #1355480641 in line 347 of C:\wamp64\www\demo\Packages\Framework\Neos.Flow\Classes\Core\Booting\Scripts.php: The system cannot find the path specified.



    [array] =>

(Soren Malling) #4

You can’t use “.” in windows, just call it as flow.bat server:run


(Prafulla Kumar Sahu) #5

flow.bat server:run and php ./flow.bat server:run is giving same result.

C:\wamp64\www\demo>flow.bat server:run
The system cannot find the path specified.

  Type: Neos\Flow\Core\Booting\Exception\SubProcessException
  Code: 1355480641
  File: C:\wamp64\www\demo\Packages\Framework\Neos.Flow\Classes\Core\Booting\Script
        s.php
  Line: 677

Open Data/Logs/Exceptions/20180706103927d4b9b0.txt for a full stack trace.

And log file content is

Exception #1355480641 in line 347 of C:\wamp64\www\demo\Packages\Framework\Neos.Flow\Classes\Core\Booting\Scripts.php: The system cannot find the path specified.



    [array] =>

(Christian Müller) #6

This looks like you modified the Flow Settings.yaml which you shouldn’t. See comment of the file oyu posted:

Don’t modify this file but add configuration options to the Settings.yaml file in the in global Configuration/ directory instead.

Maybe try that because it could just be that your configuration was overridden somewhere else.


(Prafulla Kumar Sahu) #7

Sir, even after undoing modification to settings.yaml file, I am getting same error.


(Christian Müller) #8

But did you put that configuraiton in your global Settings.yaml as well just as the comment says?


(Prafulla Kumar Sahu) #9

Sir, could you please let me know the path of global Settings.yaml? Where I was making changes is Packages/Framework/Neos.Flow/Configuration/Settings.yaml. And that is not changing the situation.

Update:

I changed Configuration/Development/Settings.yaml after watching your youtube tutorial for manual installtion. But still I am getting same error.

Now my Configuration/Development/Settings.yaml file is, I also tried with out adding " Neos.Flow.core.phpBinaryPathAndFilename to C:/xampp/php/php.exe", but that too was not working.

#                                                                        #
# Example Settings                                                       #
#                                                                        #
# This file contains settings for various parts of the application.      #
# Copy this file to Settings.yaml, and adjust as necessary.              #
#                                                                        #
# Please refer to the default settings file(s) or the manuals for        #
# possible configuration options.                                        #
#                                                                        #

Neos:
  Flow:
    persistence:
      # For a reference of the possible options, take a look at
      # https://www.doctrine-project.org/projects/doctrine-dbal/en/latest/reference/configuration.html
      backendOptions:
        dbname: 'demoapp'       # adjust to your database name
        user: 'root'             # adjust to your database user
        password: ''         # adjust to your database password

       # if you want to log executed SQL queries, enable the next 2 lines
#      doctrine:
#        sqlLogger: 'Neos\Flow\Persistence\Doctrine\Logging\SqlLogger'
    core: 
        phpBinaryPathAndFilename: 'C:/wamp64/bin/php/php7.2.4/php.exe'

(Prafulla Kumar Sahu) #10

Finally able to install it correctly in wamp server, but I am getting a blank site where as the documentation showing a page with demo content and menu. Removing the Data/Temporary directory and recompiling was the key to process it error free.