Problems installing Neos: Setup cant load resources

Hi all,

I am trying to set up Neos on a shared hosting account (Uberspace). I downloaded the package with composer create-project typo3/neos-base-distribution Neos into the subdirectory “Neos” in /var/www/virtual/$USER/.

Then I symlinked my domain to /var/www/virtual/$USER/Neos/Web.

I created the Settings.yaml myself because upon entereding, the site would just keep loading. The Settings include phpBinaryPathAndFilename and backendOptions.

I can reach the setup just fine, but the pages won’t load any resources past the original HTML. All CSS and JS files return 404.

I have tried running ./flow node:repair and ./flow resource:publish but that didnt change anything.

(Additionally, I encountered an Internal Server Error after importing a site package on step 4 of the setup. It also seems like whenever I run that step I receive a warning message from my hoster that php-cgi was using absurd amounts of RAM and was stopped because of that.

I restarted the setup and skipped that step and I seem to be able to access the demo site – just in plain HTML.)

I assume this has something to do with my webserver configuration or Rewriting in Apache but right now I don’t really know where to start or what to do to solve this.

Even if this might not be a problem with Neos itself, I’d still highly appreciate any help.


First check if resource:publish did something (aka there is stuff in Web/_Resources). Then check the .htaccess file that we deliver with Neos. It should contain all needed rewrite rules.

Hi, thanks for the reply, thanks for the suggestion.

Yes, there are files in that folder. Been there from the start.

I left both htaccess files untouched (and what they contain seems reasonable to me). Are there any standard settings that could potentially cause this? If I changed e.g. RewriteBase, nothing at all would work. (I ceased from pasting the contents of the .htaccess files because it would make this post pretty long and theyre default anyways but I can do so if it helps.)

The URLs that dont work look like this:


the domain points to Neos/Web. I assume that’s how they’re supposed to look.

Would be really happy about any pointers, I am kind of at a loss here.


Alright, I seem to have more or less found the issue.

The problems were caused by an incomplete import of the demo site. When importing TYPO3.NeosDemoTypo3Org, the default site it suggests you in the setup, my host (Uberspace) terminates the process because it is using too much memory.

How this affected the setup and that the setup wasnt able to load the resources either I dont know.

After running ./flow site:prune the setup was able to load all the assets.

Now what I did to get up and running was to not import that demo site but create my own dummy site. I assume you can do that via the setup GUI, I did it with a bit more complicated: with ./flow kickstart:site and then I went through the setup again and picked my freshly created site from the dropdown.

Now I dont have the demo site package but I’m fine with that as long as im up and running.

Ok, good to know!