[SOLVED] Flow is missing php7.1, but its installed (Hoster: WebGo)


(Leo .) #1

Hello dear NEOS community!

I’m pretty new to all this. NEOS seems like the perfect CMS for my project, yet I’ve got some trouble setting it up, more specifically: it won’t let me run flow inside the NEOS directory.

Instead, it spits out this message: " Flow requires PHP version 7.1.0 or higher but your installed version is currently 7.0.27-0+deb9u1 " + the Error #1172215790 and these details:

Type: Neos\Flow\Core\Booting\Exception\SubProcessException
Code: 1355480641
File: Packages/Framework/Neos.Flow/Classes/Core/Booting/Scripts.php
Line: 665

However, the PHP v 7.2 is installed. And even a direct call/link doesn’t change anything, it just grabs “the standard” version.

php_version_72
webserver settings


ssh console

Have a nice day,
Leo


(Bastian Heist) #2

Hi Leo,
the behaviour is indeed a bit hard to understand. Flow calls itself via the CLI internally when it compiles - we call that a Subrequest (which we’re btw not happy with, and will get rid of, but its still there for now).

To do these subrequests, Flow needs to know which PHP version to use. By default, it uses whatever is exposed as php on the console. If you run Flow/Neos with another PHP version, you need to tell Flow to use that internally as well. Add the following setting to your Settings.yaml:

Neos:
  Flow:
    core:
      phpBinaryPathAndFilename: /usr/bin/php72 #adapt this to your PHP version

(Leo .) #3

Hi Bastian,
thanks for the reply. I tried that, but its still not working. I also checked the yaml file extension, tried php7.2 as file (which exists too) and waited a while. Maybe this is a hoster problem?
Or are there other factors that may cause an error like this?


(Bastian Heist) #4

The file looks good. Please try removing the cache (rm -rf Data/Temporary) and see if that changes anything.


(Soren Malling) #5

Could yo try and run /usr/bin/php72 -v to see what version actually is behind that path


(Bastian Heist) #6

I am almost sure removing Data/Temporary will fix his issue :wink:
We’re working on a fix that will hint the user of this configuration error in the future:


(Leo .) #7

already did that (in the op), it is the 7.2, but flow doesnt utilize it (see the commit above).


(Leo .) #8

thanks! “./flow help” is working now. (with the prefix /usr/bin/php7.2)


(Bastian Heist) #9

Cool, sounds good.