Using FastCGI results in "500 Internal Server Error" BUG?

Hi Folks,

I installed Neos using mod_php as an Apache module. Everything works fine so far.
When i tried to install Neos using PHP as FastCGI, the installation process crashed with an Internal Server Error (500).

Might this be a Bug? I am using PHP 5.5.9 by the way :smile:


You might be missing some needed environment variables that are set via the provided .htaccess file in case of mod_php. Generally I can confirm FastCGI works fine, most on the team run it like this, I think. Here is an example for the nginx configuration block of one of our servers:

location ~ \.php$ {
  include fastcgi_params;
  fastcgi_index index.php;
  fastcgi_param FLOW_CONTEXT Production;
  fastcgi_param FLOW_REWRITEURLS 1;
  fastcgi_param FLOW_ROOTPATH /var/www/;
  fastcgi_split_path_info ^(.+\.php)(.*)$;
  fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
  fastcgi_param PATH_INFO $fastcgi_path_info;

Maybe that helps.

I had the same problem on server Ubuntu Plesk …
I found a solution here
I increased the FcgidIOTimeout with 150 and now it’s Ok
restart your server …
and before to start “setup” I did a chmod 777

Installation proceeded without problem :smile:

but after login in the backend the main menu of the demo is on the page, but there is only the user settings on the top right :frowning:

on the chrome inspector there is

GET 500 (Internal Server Error)
jQuery.ajaxTransport.send @ ContentModule-built.js?bust=6631c461a1e3:416
jQuery.extend.ajax @ ContentModule-built.js?bust=6631c461a1e3:416
(anonymous function) @ ContentModule-built.js?bust=6631c461a1e3:416
u @ ContentModule-built.js?bust=6631c461a1e3:416
u @ ContentModule-built.js?bust=6631c461a1e3:416
e.Object.createWithMixins._request @ ContentModule-built.js?bust=6631c461a1e3:416
e.Object.createWithMixins.getResource @ ContentModule-built.js?bust=6631c461a1e3:416
(anonymous function) @ ContentModule-built.js?bust=6631c461a1e3:416
u @ ContentModule-built.js?bust=6631c461a1e3:416
u @ ContentModule-built.js?bust=6631c461a1e3:416(anonymous function) @ ContentModule-built.js?bust=6631c461a1e3:416
i.execCb @ require.js:29
X.check @ require.js:18
X.enable @ require.js:23
X.init @ require.js:17
(anonymous function) @ require.js:26


could you open inspector and see what is in the response? Furthermore, please check Data/Logs/System_Development.log for an error message.

All the best,

1 Like

thank’s Sebastian
I am losted :smile:
if the inspector is in the backend … I do not see it because the backend interface has not been builded in the html page … I tried to explain the problem here No menu for editing in Neos 2.0.0 beta 5?

the response in the data/logs/exceptions

Uncaught exception #1328879703 in line 40 of /var/www/vhosts/ The path “” does not point to an existing and accessible XML file.

There was a incompatibility with the latest tagged version of the TYPO3.Neos.Seo package and the latest beta. You can fix it by running “composer clearcache” and a “composer update”. Sorry for the inconvenience.

1 Like

thank you Aske … now it’s Ok
as I have already writen … you are our savior :slight_smile:

What @sebastian meant was the browser’s developer tools inspector to see the actual XHR request result, not the inspector in the Neos UI. Too many things with the same names… :wink:

1 Like

Ok inspector Karsten !..
I understood later, but I had already sent my message before I understood :smile:
I sincerely thank the Neos team because with your help I can understand …