Hosters (SharedHostings) supporting running Neos


(Dominik Jansen) #1

Hey all,

currently I’m looking for a hoster supporting running Neos.
The last time I tried e.g. domainfactory or mittwald it was a pain in the ass.

Who has experiences in installing and running Neos on a shared hosting and can recommend it?

Let’s try to create a list - so we can save all users some time and disappointment when selecting a shared hosting.


Supported hostings:

Germany

  • 1und1
  • Webhosting Unlimited Pro
  • all-inkl
  • all-inkl Premium
  • all-inkl Business
  • Mittwald
  • Webhosting XL (Tested)
  • Webhosting XXL (should)
  • Webhosting MAX (should)
  • Netcup
  • punktDe proServer
  • Uberspace
  • Webhostone
  • Single-App (Tested)
  • Multi-App (Should)
  • Power-App (Should)

United Kingdom

  • Clook

Switzerland

  • Hostpoint.ch

Unsupported hostings:

  • Strato
  • PowerWeb Starter
  • PowerWeb Basic
  • PowerWeb Plus
  • PowerWeb Pro
  • 1und1
  • Webhosting Starter
  • Webhosting Unlimited
  • Webhosting Unlimited Plus

Untested hostings: (Please add more)

  • Domainfactory
  • MyHome Plus
  • ManagedHosting Pro
  • HostEurope
  • WebHosting Basic
  • WebHosting Medium
  • WebHosting Premium
  • WebHosting Supreme
  • jweiland
  • Webhosting Privat
  • Webhosting Business
  • Webhosting Premium
  • Webhosting Premium Plus
  • Mittwald
  • Webhosting L
  • profihost
  • Webhosting Medium
  • Webhosting Highend
  • Webhosting Business
  • Webhosting Expert

(Sebastian Kurfuerst) #2

Hey,

due to customer’s requests, we know that Strato does not work (due to PHP binary not being available); but all-inkl.com works (we found this as alternative); as long as you have SSH access.

All the best,
Sebastian


(Dominik Jansen) #3

Is Imagick/Gmagick available? I didn’t find it in the listings.


(Sebastian Helzle) #4

Hi,

Uberspace works fine.

Got a instance running there for a year now.


[Workaround found] Neos installation/setup problematic (on Uberspace)
(armin otto) #5

I tested those:

  • 1und1 Webhosting Unlimited Pro
  • Mittwald Webhosting XL

Forget the 1und1 Webhosting Unlimited Pro, it was undoable. I tried to get Neos 1.2.9 to run and I hit roadblock after roadblock. You can’t setup your webspace in a way that is compatible with Neos.
Their vserver is fine, though.

Mittwald Webhosting XL works great with Neos 1.2.9 and they offer a one-click-installer.
No Neos 2.0 support yet, though.


(David Walchli) #6

I have Neos 1.2 running on Hostpoint (.ch) with SSH access.
I had some issues setting file permissions with sudo ./flow flow:core:setfilepermissions as sudo is not available. But it works fine, except that I have to clear cache with: FLOW_CONTEXT=Production rm -r Data/Temporary; ./flow flow:cache:flush --force

Also make sure you set the PHP settings:
allow_url_fopen = On
memory_limit = 128M

And php binary in Settings.yaml like this:

TYPO3:
  Flow:
    core:
      phpBinaryPathAndFilename: /usr/local/bin/php

(Marvin Hübner) #7

Domainfactory offers a click and build installation for Neos 1.2 and 2.0. But not tested yet. (ManagedHosting Pro)


(Kerstin Huppenbauer) #8

I have some Neos Sites running in the Webhostone Single App Packages.
https://www.webhostone.de/webspace_details.html
It works well, but if you have many or huge Images you should increase the memory


(Nick Poaros) #9

I have run sites on https://www.clook.net both the shared server and now the cloud option.
With the shared server there is no shell, but I used cron to run shell scripts!
The support offered seems to me above and beyond for either package. Within 10 minutes someone would be on the case and help me resolve issues.


(John Dreadmiller) #10

C̶u̶r̶r̶e̶n̶t̶l̶y̶ ̶N̶e̶o̶s̶ ̶c̶a̶n̶n̶o̶t̶ ̶b̶e̶ ̶i̶n̶s̶t̶a̶l̶l̶e̶d̶ ̶o̶n̶ ̶U̶b̶e̶r̶s̶p̶a̶c̶e̶. For Uberspace, the suggested tutorial is currently incomplete, see the comments section there for my supplement. Standard-Procedure for installation (from the Neos-Docs) is not sufficient on Uberspace in the first place.
See also my post regarding current issues (workarounds inside).
So it is possible to make a fresh installation at the current time (with Gd at least), it’s correct that it is installable on Uberspace.


(Marcel Bucksch) #11

domain factory backend installed 2.0 works fine.
But impossible to update by the here published update procedure.


(Marcel Bucksch) #12

Neos 2.1.x is currently impossible at domainfactory. This is also confirmed by the admins.


(Bastian Waidelich) #13

Did they say why?


(Marcel Bucksch) #14

No, just that they are aware and don’t recommend to update.
They also do not know when they will fix it. Must properly not soon.

As df customer you could access the forum.

I also figured out other issues with the df backend installation that let Neos crash (like create a new site).


(Marcel Bucksch) #15

Update: DomainFactory is now providing a Neos 2.1 installation from the df backend. The installation went well so far.


(Rafael Kähm) #16

Just installed Neos on Netcups “Web Expert Light”.

You must just do a two little tricks to run Neos on each Netcups Webhosting tariff.

  1. Change Webost root path. Just change “/httpdocs” to “/httpdocs/Web” in control panel.
  2. Set In Settings.yaml
TYPO3:
  Flow:
    core:
      # see exact path for /var/www/vhosts/yousServerHost.netcup.net/ in phpinfo()'s "open_basedir" var and attach "/usr/local/php56/bin/php" or /usr/local/php55/bin/php depending on PHP version for web.
      phpBinaryPathAndFilename: /var/www/vhosts/yousServerHost.netcup.net/usr/local/php56/bin/php

This hoster uses CHROOT for SSH and the paths in SSH and Web are different, therefore do not warm-up caches over SSH untill #187 is merged and relative symlinks are enabled!

Some other Tipps:

  1. Set PHP version for SSH:
    1.1. mkdir /binaries
    1.2. ln -s /usr/local/php56/bin/php /binaries/php
    1.3. echo 'export PATH=/binaries:$PATH' > ~/.bash_profile
    1.4. relogin in SSH

  2. Install Composer
    2.1 curl -s https://getcomposer.org/installer | php -- --install-dir=/binaries --filename=composer

The value on max exec time is limited to 60, therefore sometimes you get errors within Neos setup, it’s not nasty -> just reload the page. After that Neos runs very well on this Webhosting platform.

So good luck with Netcup!


(Christian Müller) #17

Until the chnage is merged you can always install https://github.com/mittwald/flow-symlink-publishing which is the same code.


(Rafael Kähm) #18

Small update.

with neos/setup/pull/2 it is possible to use regular(also not from CHROOT as described in my prev. post) PHP CLI binaries on shared hostings like Plesk

Also just putting desired version is enought

TYPO3:
  Flow:
    core:
      phpBinaryPathAndFilename: '/usr/local/php56/bin/php'

(Daniel Lienert) #19

Hey,

We at punkt.de are currently launching a hosting solution espacially tailored for Neos and Flow hosting. It is called proServer. It is a virtual managed root server that provides any tool that you need for advanced neos projects.
The pages are in german only for now, but if you have any questions I would be glad to answer them.


(Peter Berger) #20

Hi David

I try to run Neos on hostpoint.ch as well but without success. Can I get in touch with you to discuss this ?

Kind regards
peter.berger@bluewin.ch